SCP Questions of This Month: September

This post is a collection of questions and answers about the Semi-Automatic Classification Plugin (SCP) and remote sensing which were discussed in the Facebook group and the Google+ Community this month.
These questions vary from supervised classification technique to software issues, and can be useful to the readers of this blog for solving issues about the use of SCP.

Question

I was creating a ROI in SCP and unfortunately while doing so, the following message appeared and suddenly the whole work crashed.

How can I solve this?

Answer

It is probably a dependency issue. You can try to install QGIS again.
Also, you can try this virtual machine http://semiautomaticclassificationmanual-v5.readthedocs.io/en/latest/semi-automatic_os.html

Question

What could be the finest scale of LULC generated using Sentinel data using Semi Automatic Classification ?

Answer

Given the spatial resolution of 10m the scale could be 1:20,000 .

Question

I want to compare two classification images of land use. I did this with the Land Cover Change. I don't understand the results.

Answer

The result is a code (ChangeCode) assigned to each combination of class values (reference and new class), and the pixelSum is the count of pixels for each combination
The result of Land Cover Change is a raster with the ChangeCode values.
Please read http://semiautomaticclassificationmanual-v5.readthedocs.io/en/latest/main_interface_window.html#land-cover-change

Question

Is it possible to evaluate Band separability with SCP? 

Answer

Yes it is possible. Please watch https://youtu.be/FcETq8OWM0k?t=22m26s

Question

I am facing authentication error while logging in with SCP, although i can logged in
https://scihub.copernicus.eu/dhus/ using my use and password. 

Answer

You should wait a few days after the registration for accessing Sentinel-2 images with SCP

Question

I need to classify and calculate NDVI of an image, but with cloud inside my area. How I can create a mask in the process?

Answer

Please watch this old tutorial https://www.youtube.com/watch?v=acxmIrM-Qns

Question


I just installed QGIS 2.18.12 on Linux and when I install Semi-Automactic Plugin, I get this error. 

Now uninstall and reinstall and continue with the same issue. How can I solve it? 

Answer

It is a dependency issue. You should install QGIS again with all the required dependencies (read http://semiautomaticclassificationmanual-v5.readthedocs.io/en/latest/installation_ubuntu.html)


For any comment or question, join the Facebook group and the Google+ Community about the Semi-Automatic Classification Plugin.

Newer posts Older posts

Follow

RG